tardis-machine v3.22.0: support coinbase authenticated channels and fallback to level2_batch for l2 data for non authenticated connections
Incident Report for Tardis.dev
Resolved
This incident has been resolved.
Posted May 31, 2023 - 05:14 UTC
Investigating
Coinbase real-time feeds now by default use level2_batch for l2 data, but when authenticated will use level2 (non batched real-time channel). This is caused by following incoming Coinbase API changes:
https://docs.cloud.coinbase.com/exchange/docs/upcoming-changes
ENFORCED AUTHENTICATION
2023-MAY-03
Effective July 1, 2023, the following WebSocket feeds on Coinbase Exchange will require authentication:

Full Channel
Level2 Channel
Level3 Channel



In order to authenticate Coinbase API connections following environment variables need to be set:
- COINBASE_API_KEY
- COINBASE_API_SECRET
- COINBASE_API_PASSPHRASE

https://github.com/tardis-dev/tardis-node/commit/501a3eaa9ba0ca376230cb384966cfa630fc33b3
Posted May 30, 2023 - 13:30 UTC
This incident affected: Tardis Machine Important Updates.